|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- step through the list of registered network protocols
#include <sys/neti.h> net_data_t *net_protocol_walk(net_data_t net);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
The net_protocol_walk() function walks through all of the network protocols that have been registered with this interface. The initial call to net_protocol_walk() should be made by passing in NULL as the value for net. When this function returns NULL, the end of the list has been reached.
A caller of net_protocol_walk() is required to walk through the entire list of network protocols, until NULL is returned or, when finished with using the value returned, pass it into a call to net_protocol_release(9F).
The net_protocol_walk() function returns NULL when the end of the list is returned. Otherwise, it returns a non-NULL value as a token for being passed into other function calls within this interface.
The net_protocol_walk() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: