|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- parse the Byte Order tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_BYTEORDER(client_handle_t ch, tuple_t *tu, cistpl_byteorder_t *cbo);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_byteorder_t structure which contains the parsed CISTPL_BYTEORDER tuple information upon return from this function.
This function parses the Byte Order tuple, CISTPL_BYTEORDER, into a form usable by PC Card drivers.
The CISTPL_BYTEORDER tuple shall only appear in a partition tuple set for a memory-like partition. It specifies two parameters: the order for multi-byte data, and the order in which bytes map into words for 16-bit cards.
The structure members of cistpl_byteorder_t are:
uint32_t order; /* byte order code */ uint32_t map; /* byte mapping code */
The fields are defined as follows:
This field specifies the byte order for multi-byte numeric data.
Little endian order
This field specifies the byte mapping for 16-bit or wider cards.
Byte zero is least significant byte
Byte zero is most significant byte
Vendor specific mapping
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA