|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- return the number of bytes in a message
#include <sys/stream.h> size_t msgdsize(mblk_t *mp);
Architecture independent level 1 (DDI/DKI).
Message to be evaluated.
The msgdsize() function counts the number of bytes in a data message. Only bytes included in the data blocks of type M_DATA are included in the count.
The number of data bytes in a message, expressed as an integer.
The msgdsize() function can be called from user, interrupt, or kernel context.
See bufcall(9F) for an example that uses msgdsize().