|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- parse the Geometry tuple
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_GEOMETRY(client_handle_t ch, tuple_t *tu, cistpl_geometry_t *pt);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a cistpl_geometry_t structure which contains the parsed CISTPL_GEOMETRY tuple information upon return from this function.
This function parses the Geometry tuple, CISTPL_GEOMETRY, into a form usable by PC Card drivers.
The CISTPL_GEOMETRY tuple indicates the geometry of a disk-like device.
The structure members of cistpl_geometry_t are:
uint32_t spt; uint32_t tpc; uint32_t ncyl;
The fields are defined as follows:
This field indicates the number of sectors per track.
This field indicates the number of tracks per cylinder.
This field indicates the number of cylinders.
Client handle is invalid.
Parser does not know how to parse tuple.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA