|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- convert between an integer and a decimal string
#include <sys/ddi.h> int stoi(char **str);
void numtos(unsigned long num, char *s);
Solaris DDI specific (Solaris DDI).
Pointer to a character string to be converted.
Decimal number to be converted to a character string.
Character buffer to hold converted decimal number.
The stoi() function returns the integer value of a string of decimal numeric characters beginning at **str. No overflow checking is done. *str is updated to point at the last character examined.
The numtos() function converts a long into a null-terminated character string. No bounds checking is done. The caller must ensure there is enough space to hold the result.
The stoi() function returns the integer value of the string str.
The stoi() function can be called from user, interrupt, or kernel context.
The stoi() function handles only positive integers; it does not handle leading minus signs.