|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- cancel a pending qbufcall request
#include <sys/stream.h> #include <sys/ddi.h> void qunbufcall(queue_t *q, bufcall_id_t id);
Solaris DDI specific (Solaris DDI).
Pointer to STREAMS queue_t structure.
Identifier returned from qbufcall(9F).
The qunbufcall() function cancels a pending qbufcall() request. The argument id is a non-zero identifier of the request to be cancelled. id is returned from the qbufcall() function used to issue the cancel request.
The qunbufcall() function is tailored to be used with the enhanced STREAMS framework interface which is based on the concept of perimeters. (See mt-streams(9F).) qunbufcall() returns when the bufcall has been cancelled or finished executing. The bufcall will be cancelled even if it is blocked at the perimeters associated with the queue. All outstanding timeouts and bufcalls must be cancelled before a driver close routine can block and before the close routine calls qprocsoff(9F).
The qunbufcall() function can be called from user, interrupt, or kernel context.