|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- announce a device
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> void ddi_report_dev(dev_info_t *dip);
Solaris DDI specific (Solaris DDI).
a pointer the device's dev_info structure.
ddi_report_dev() prints a banner at boot time, announcing the device pointed to by dip. The banner is always placed in the system logfile (displayed by dmesg(1M)), but is only displayed on the console if the system was booted with the verbose (-v) argument.
ddi_report_dev() can be called from user context.