|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- prevent a queue from being scheduled
#include <sys/stream.h> #include <sys/ddi.h> void noenable(queue_t *q);
Architecture independent level 1 (DDI/DKI).
Pointer to the queue.
The noenable() function prevents the q from being scheduled for service by insq(9F), putq(9F) or putbq(9F) when enqueuing an ordinary priority message. The queue can be re-enabled with the enableok(9F) function.
The noenable() function can be called from user, interrupt, or kernel context.