|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- Device strategy request
#include <sys/sunldi.h> int ldi_strategy(ldi_handle_t lh, struct buf *bp);
Pointer to the buf(9S) structure.
The ldi_strategy() function passes a strategy request to the device entry point for the device specified by the layered handle. This operation is supported for block devices.
The ldi_strategy() function returns 0 if the strategy request has been passed on to the target device. Other possible return values are:
Invalid input parameters.
Operation is not supported for this device.
Once the request has been passed on to the target devices strategy entry point, any further errors will be reported by bioerror(9F) and biodone(9F). See the strategy(9E) entry point for more information.
This function may be called from user or kernel context.