|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- report the impact of an error
#include <sys/ddifm.h> void ddi_fm_service_impact(dev_info_t *dip, int *impact);
Solaris DDI specific (Solaris DDI)
Pointer to the dev_info structure
Impact of error
The following service impact values are accepted by ddi_fm_service_impact():
The service provided by the device is unavailable due to an error. The operational state of the device will transition to DEVI_DEVICE_DOWN.
The driver is unable to provide normal service, but it can provide a partial or degraded level of service. The driver might have to make repeated attempts to perform an operation before it succeeds, or it may be running at less than its configured speed. A driver may use this value to indicate that an alternative device should be used if available, but that it can continue operation if no alternative exists. The operational state of the device will transition to DEVI_DEVICE_DEGRADED.
The service provided by the device has been restored. The operational state of the device will transition to its pre-error condition state and DEVI_DEVICE_DOWN or DEVI_DEVICE_DEGRADED is removed.
The service provided by the device was unaffected by the error.
The ddi_fm_service_impact() function can be called from user, kernel, or high-level interrupt context.
See attributes(5) for descriptions of the following attributes: