|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- test for room in a message queue
#include <sys/stream.h> int canput(queue_t *q);
Architecture independent level 1 (DDI/DKI).
Pointer to the message queue.
canput() searches through the stream (starting at q) until it finds a queue containing a service routine where the message can be enqueued, or until it reaches the end of the stream. If found, the queue containing the service routine is tested to see if there is room for a message in the queue.
canputnext(q) and bcanputnext(q, pri) should always be used in preference to canput(q->q_next) and bcanput(q->q_next, pri) respectively.
If the message queue is not full.
If the queue is full.
canput() can be called from user or interrupt context.
Drivers are responsible for both testing a queue with canput() and refraining from placing a message on the queue if canput() fails.