|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- report current DMA window offset and size
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_curwin(ddi_dma_handle_t handle, off_t *offp, uint_t *lenp);
This interface is obsolete. ddi_dma_getwin(9F) should be used instead.
The DMA handle filled in by a call to ddi_dma_setup(9F).
A pointer to a value which will be filled in with the current offset from the beginning of the object that is mapped for DMA.
A pointer to a value which will be filled in with the size, in bytes, of the current window onto the object that is mapped for DMA.
The ddi_dma_curwin() function reports the current DMA window offset and size. If a DMA mapping allows partial mapping, that is if the DDI_DMA_PARTIAL flag in the ddi_dma_req(9S) structure is set, its current (effective) DMA window offset and size can be obtained by a call to ddi_dma_curwin().
The ddi_dma_curwin() function returns:
The current length and offset can be established.
The ddi_dma_curwin() function can be called from user, interrupt, or kernel context.
See attributes(5) for a description of the following attributes: