|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- Retrieve device USB address
#include <sys/usb/usba.h> int usb_get_addr(dev_info_t *dip);
Solaris DDI specific (Solaris DDI)
Pointer to the device's dev_info structure.
The usb_get_addr() function returns the current USB bus address for debugging purposes. The returned address is unique for a specific USB bus, and may be replicated if multiple host controller instances are present on the system.
On success: USB device address.
On failure: returns 0. Fails if dip is NULL.
May be called from user, kernel or interrupt context.
int usb_addr; usb_addr = usb_get_addr(dip);
See attributes(5) for descriptions of the following attributes: