|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- remove all callbacks for a given callback ID
#include <sys/sunldi.h> void ldi_ev_remove_callbacks(ldi_ev_callback_id_t id);
Solaris DDI specific (Solaris DDI)
An opaque data structure returned on successful calls to ldi_ev_register_callbacks(9F).
The ldi_ev_remove_callback() function unregisters any callbacks that were registered via ldi_ev_register_callbacks(9F). Once this function returns, the callback ID is no longer valid.
The finalize and notify callbacks exist independently of the LDI handle and are not automatically removed when the LDI handle is closed. The layered driver removes these callbacks via ldi_ev_remove_callbacks()() when the callbacks are no longer needed. The LDI framework may panic the system if the entity registering the callback (a dev_t, dip or module) no longer exists on the system and the callbacks have not been unregistered.
This function can be called from user and kernel contexts only.