|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- free all message blocks in a message
#include <sys/stream.h> void freemsg(mblk_t *mp);
Architecture independent level 1 (DDI/DKI).
Pointer to the message blocks to be deallocated. mblk_t is an instance of the msgb(9S) structure. If mp is NULL, freemsg() immediately returns.
The freemsg() function calls freeb(9F) to free all message and data blocks associated with the message pointed to by mp.
The freemsg() function can be called from user, interrupt, or kernel context.
Example 1 Using freemsg()
The behavior of freemsg() when passed a NULL pointer is Solaris-specific.