|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- concatenate two message blocks
#include <sys/stream.h> void linkb(mblk_t *mp1, mblk_t *mp2);
Architecture independent level 1 (DDI/DKI).
The linkb() function creates a new message by adding mp2 to the tail of mp1. The continuation pointer, b_cont, of mp1 is set to point to mp2.
The following figure describes how the linkb(m1, m2); function concatenates two message blocks, mp1 and mp2:
The message to which mp2 is to be added. mblk_t is an instance of the msgb(9S) structure.
The message to be added.
The linkb() function can be called from user, interrupt, or kernel context.
See dupb(9F) for an example that uses linkb().