|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- remove a kstat for a specific instance of IP from the system
#include <sys/types.h> #include <sys/kstat.h> #include <sys/neti.h> void net_kstat_delete(netid_t netid, kstat_t *ksp);
Solaris DDI specific (Solaris DDI).
IP instance identifier.
Pointer to a currently installed kstat(9S) structure.
The net_kstat_delete() function removes ksp from the kstat chain and frees all associated system resources. See kstat_delete(9F) for a complete discussion of this function.
If successful, net_kstat_delete() returns a pointer to the allocated kstat. NULL is returned upon failure.
The net_kstat_delete() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: