Go to main content

man pages section 5: File Formats

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

alias(5)

Name

alias - alias table file of codeset names

Synopsis

/usr/lib/iconv/alias

Description

This file contains an alias table of codeset names for cconv_open(3C) and iconv_open(3C).

The allowed alias definitions are one of the following:

"%s %s\n", <codeset name alias>, <canonical codeset name>
"*%s %s %s\n", <normalized codeset name alias>,
                      <codeset name alias>, <canonical codeset name>
"%s %s, %d\n", <codeset name alias>, <canonical codeset name>,
                      <variant level>
"*%s %s %s, %d\n", <normalized codeset name alias>,
                      <codeset name alias>, <canonical codeset name>,
                      <variant level>

which means that the codeset name alias maps to the canonical codeset name. The variant level which is a positive integer indicates which variant of the canonical codeset should be used in the code conversion. For the descriptions and supported variant levels, refer to iconv_unicode(7) and other section 5 iconv man pages.

During the mapping process, the string specified for the codeset name alias is normalized by extracting only alphanumeric and '+' (i.e., 0x2b) characters as significant characters and then applying to lowercase conversions to the extracted characters for a better success ratio of possible mappings.

When a normalized codeset name alias is supplied, it is used without any further normalization yielding better performance in the mapping process.

Any ill-formed lines are simply ignored.

A line beginning with '#' is treated as a comment.

Examples

Alias definitions

The following shows four different alias definitions possible:

# Various definitions are possible:
ISO-8859-1 ISO8859-1
*iso88592 ISO-8859-2 ISO8859-2
ISO-8859-15 ISO8859-1,1
*koi8u KOI8U KOI8-R,1

The first one simply maps ISO-8859-1 and any possible variations of it, e.g., iso-8859-1, iso8859-1, ISO8859:1, and so on, to ISO8859-1. The second one does similar thing for ISO8859-2 but since a normalized alias name is supplied, the mapping will be done quicker. The third one will map any variations of ISO-8859-15 into ISO8859-1 with variant level value of 1. The fourth one does similar thing for KOI8-U but since a normalized alias name is supplied, the mapping will be done quicker.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

iconv(1), cconv(3C), cconv_close(3C), cconv_open(3C), cconvctl(3C), iconv(3C), iconv_close(3C), iconv_open(3C), iconvctl(3C), attributes(7), iconv_extra(7), iconv_ja(7), iconv_ko(7), iconv_unicode(7), iconv_zh(7), iconv_zh_HK(7), iconv_zh_TW(7)

Notes

For the supported canonical and alias names in the current system, refer to "iconv -l" output.