Go to main content

man pages section 5: File Formats

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

webui-preferences-json (5)

Name

webui-preferences-json - Web UI Preferences JSON File format

Description

The Oracle Solaris Web UI uses JSON (JavaScript Object Notation) for the storage of the various configurable options. See webui-preferences(7) manual page for more information on how to deliver these files.

The format of the preferences JSON file is defined by the JSON Schema that is delivered by the packaging system.

It is possible for administrators to deliver JSON files that override the delivered defaults in the specified site directories as outlined in webui-preferences(7).

Format

The JSON preferences file takes the basic form:

       {
          "global": {
               "<version>": {
                    "<prop_1>": <prop_value>,
                    "<prop_2>": {
                        "<sub_prop_2_1>": <prop_value>
                    },
                    "<prop_N>": <prop_value>
                }
            }
            "apps": {
              "<app_name>": {
                   "<version>": {
                        "<prop_1>": <prop_value>,
                        "<prop_2>": {
                            "<sub_prop_2_1>": <prop_value>
                        },
                        "<prop_N>": <prop_value>
                    }
                }
            }
        }

Fields

namespaces

There is a namespace for each set of preferences, where "global" is the namespace for the setting of any global preferences that would be relevant to the Web UI as a whole.

The "apps/<app_name>" namespace contains any preferences that are for any specific installed application (for example, "analytics").

<version>

For each namespace, there is a version associated. If you wish to set a specific preference for a specific version, you should specify a version here.

<prop_*>

To actually change a value, you should provide the name of the property, and the new value. Some properties may be part of the value for another property, like "<sub_prop_2_1>" is above.

Exactly where the property you wish to set is located should be determined by looking at the delivered JSON files and/or the JSON Schema.

Examples

Example 1 Setting the Web UI to Use Large Fonts by Default
        {
            "global": {
                "v1": {
                    "accessibility": {
                        "large_fonts": true
                    }
                }
            }
        }
Example 2 The Home Sheet in the Analytics Application to one of the Existing Sheets Identified by the UUID
06217390-1c04-11e5-bd3f-8b3fe05a2bd3

The JSON would look like:

       {
            "apps": {
                "analytics": {
                    "v1": {
                        "homeSheet": "06217390-1c04-11e5-bd3f-8b3fe05a2bd3"
                    }
                }
            }
        }

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Private

See Also

webui-preferences(7)