Go to main content

man pages section 5: File Formats

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Tttttk (5)

Name

Tttttk - ToolTalk definitions

Synopsis

#include <Tt/tttk.h>

Description

tttk(5)                      ToolTalk Definitions                      tttk(5)



NAME
       tttk, Tttttk - ToolTalk definitions

SYNOPSIS
       #include <Tt/tttk.h>

DESCRIPTION
       The  <Tt/tttk.h>  header  defines  the following enumeration data type,
       with at least the following members:

          Tttk_op
                TTDT_CREATED, TTDT_DELETED, TTDT_DO_COMMAND, TTDT_GET_ENVIRON-
                MENT, TTDT_GET_GEOMETRY, TTDT_GET_ICONIFIED, TTDT_GET_LOCALE,
                TTDT_GET_MAPPED, TTDT_GET_MODIFIED, TTDT_GET_SITUATION,
                TTDT_GET_STATUS, TTDT_GET_SYSINFO, TTDT_GET_XINFO, TTDT_LOWER,
                TTDT_MODIFIED, TTDT_MOVED, TTDT_OP_LAST, TTDT_OP_NONE,
                TTDT_PAUSE, TTDT_QUIT, TTDT_RAISE, TTDT_RESUME, TTDT_REVERT,
                TTDT_REVERTED, TTDT_SAVE, TTDT_SAVED, TTDT_SET_ENVIRONMENT,
                TTDT_SET_GEOMETRY, TTDT_SET_ICONIFIED, TTDT_SET_LOCALE,
                TTDT_SET_MAPPED, TTDT_SET_SITUATION, TTDT_SET_XINFO, TTDT_SIG-
                NAL, TTDT_STARTED, TTDT_STATUS, TTDT_STOPPED, TTME_ABSTRACT,
                TTME_COMPOSE, TTME_DEPOSIT, TTME_DISPLAY, TTME_EDIT,
                TTME_INTERPRET, TTME_MAIL, TTME_MAIL_COMPOSE, TTME_MAIL_EDIT,
                TTME_PRINT, TTME_TRANSLATE

       The header declares the following  global  string  constants  for  some
       standard vtypes:

       extern const char  *Tttk_boolean:
       extern const char  *Tttk_file:
       extern const char  *Tttk_height:
       extern const char  *Tttk_integer:
       extern const char  *Tttk_message_id:
       extern const char  *Tttk_string:
       extern const char  *Tttk_title:
       extern const char  *Tttk_width:
       extern const char  *Tttk_xoffset:
       extern const char  *Tttk_yoffset:

       The header declares the following as functions:

       int ttdt_Get_Modified(Tt_message context,
                             const char *pathname,
                             Tt_scope the_scope,
                             XtAppContext app2run,
                             int ms_timeout);

       Tt_status ttdt_Revert(Tt_message context,
                             const char *pathname,
                             Tt_scope the_scope,
                             XtAppContext app2run,
                             int ms_timeout);

       Tt_status ttdt_Save(Tt_message context,
                           const char *pathname,
                           Tt_scope the_scope,
                           XtAppContext app2run,
                           int ms_timeout);

       Tt_status ttdt_close(const char *procid,
                            const char *new_procid,
                            int sendStopped);

       Tt_status ttdt_file_event(Tt_message context,
                                 Tttk_op event,
                                 Tt_pattern *patterns,
                                 int send);

       Tt_pattern *ttdt_file_join(const char *pathname,
                                  Tt_scope the_scope,
                                  int join,
                                  Ttdt_file_cb cb,
                                  void *clientdata);

       Tt_message ttdt_file_notice(Tt_message context,
                                   Tttk_op op,
                                   Tt_scope scope,
                                   const char *pathname,
                                   int send_and_destroy);

       Tt_status ttdt_file_quit(Tt_pattern *patterns,
                                int quit);

       Tt_message ttdt_file_request(Tt_message context,
                                    Tttk_op op,
                                    Tt_scope scope,
                                    const char *pathname,
                                    Ttdt_file_cb cb,
                                    void *client_data,
                                    int send_and_destroy);

       Tt_pattern *ttdt_message_accept(Tt_message contract,
                                       Ttdt_contract_cb cb,
                                       void *clientdata,
                                       Widget shell,
                                       int accept,
                                       int sendStatus);

       char *ttdt_open(int *ttfd,
                       const char *toolname,
                       const char *vendor,
                       const char *version,
                       int sendStarted);

       Tt_status ttdt_sender_imprint_on(const char *handler,
                                        Tt_message contract,
                                        char **display,
                                        int *width,
                                        int *height,
                                        int *xoffset,
                                        int *yoffset,
                                        XtAppContext app2run,
                                        int ms_timeout);

       Tt_pattern *ttdt_session_join(const char *sessid,
                                     Ttdt_contract_cb cb,
                                     Widget shell,
                                     void *clientdata,
                                     int join);

       Tt_status ttdt_session_quit(const char *sessid,
                                   Tt_pattern *sess_pats,
                                   int quit);

       Tt_pattern *ttdt_subcontract_manage(Tt_message subcontract,
                                           Ttdt_contract_cb cb,
                                           Widget shell,
                                           void *clientdata);

       Tt_status ttmedia_Deposit(Tt_message load_contract,
                                 const char *buffer_id,
                                 const char *media_type,
                                 const unsigned char *new_contents,
                                 int new_len,
                                 const char *pathname,
                                 XtAppContext app2run,
                                 int ms_timeout);

       Tt_message ttmedia_load(Tt_message context,
                               Ttmedia_load_msg_cb cb,
                               void *clientdata,
                               Tttk_op op,
                               const char *media_type,
                               const unsigned char *contents,
                               int len,
                               const char *file,
                               const char *docname,
                               int send);

       Tt_message ttmedia_load_reply(Tt_message contract,
                                     const unsigned char *new_contents,
                                     int new_len,
                                     int reply_and_destroy);

       Tt_status ttmedia_ptype_declare(const char *ptype,
                                       int base_opnum,
                                       Ttmedia_load_pat_cb cb,
                                       void *clientdata,
                                       int declare);

       void tttk_Xt_input_handler(XtPointer procid,
                                  int *source,
                                  XtInputId *id);

       Tt_status tttk_block_while(XtAppContext app2run,
                                  const int *blocked,
                                  int ms_timeout);

       Tt_status tttk_message_abandon(Tt_message msg);

       Tt_message tttk_message_create(Tt_message context,
                                      Tt_class the_class,
                                      Tt_scope the_scope,
                                      const char *handler,
                                      const char *op,
                                      Tt_message_callback callback);

       Tt_status tttk_message_destroy(Tt_message msg);

       Tt_status tttk_message_fail(Tt_message msg,
                                   Tt_status status,
                                   const char *status_string,
                                   int destroy);

       Tt_status tttk_message_reject(Tt_message msg,
                                     Tt_status status,
                                     const char *status_string,
                                     int destroy);

       char *tttk_op_string(Tttk_op opcode);

       Tttk_op tttk_string_op(const char *opstring);

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

ToolTalk 1.3                     1 March 1996                          tttk(5)