Go to main content

man pages section 5: File Formats

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

odoc-bundle (5)

Name

odoc-bundle - Online Docs Bundlespec file format

Description

Bundle specfile is a JSON file sourced by odoctool createbundle subcommand. It contains metadata about bundle itself as well as pointers to actual content source files. For more information, see the odoctool(1) man page.

Format

Each bundlespec file must validate against schema definition file /usr/share/odoc/schema/bundlespec.json which also contains full set of available fields.

Minimal bundlespec file looks like:

{
        "id": "example",
        "lang": "en",
        "group": "api",

        "sources": [{
            "file": "test1.article",
            "source_format": "docbook"
	 },{
    	 "file": "test2.article",
	     "source_format": "docbook"
	 }]
}

Field id is mandatory and contains unique bundle identifier of [a-zA-Z0-9\-_] characters.

Field lang is mandatory and defines bundle language. The valid Oracle Solaris core languages are:

de       (German)
en       (English)
es       (Spanish)
fr       (French)
it       (Italian)
ja       (Japanese)
ko       (Korean)
pt_BR    (Portuguese - Brazilian)
zh_CN    (Chinese - Simplified)
zh_TW    (Chinese - Traditional)

Field group is mandatory and determines into which content group documents will belong to. The content groups can be any one of: tech, api, book, refman, and hw.

Field sources is a JSON array of objects describing where odoctool should find sources and in which format.

Each bundlespec file must contain at least one sources object.

See Also

odoctool(1)