|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- FTP Server conversions database
When the FTP Server, in.ftpd(1M), receives the retrieve (RETR) command, if the specified file does not exist, it looks for a conversion to change an existing file or directory of the same base name into the format requested, subject to the ftpaccess(4) compress and tar capabilities.
The conversions and their attributes known by in.ftpd(1M) are stored in an ASCII file of the following format. Each line in the file provides a description for a single conversion. The fields in this file are separated by colons (:).
%s:%s:%s:%s:%s:%s:%s:%s 1 2 3 4 5 6 7 8
The fields are described as follows:
The Strip prefix and Addon prefix fields are not currently supported.
The Strip postfix and addon postfix fields are extensions to be added to or removed from the requested filename in attempting to produce the name of an existing file or directory. When the attempt succeeds, the FTP Server runs the external command associated with the conversion. The magic cookie %s in the argument is passed to the command, replaced with the name of the existing file or directory.
External command is the absolute pathname of a command to run followed by the appropriate options to carry out the conversion. The standard output of the command is sent back in response to the RETR (retrieve) command. For anonymous and guest users to be able to execute the command, it must be present in their chroot'd hierarchy along with any necessary dynamic libraries.
Types specifies the conversion type. The following values are recognized:
ASCII transfers are allowed of a file produced by the conversion.
Directories can be converted.
Regular files can be converted.
Options are checked against the ftpaccess(4) compress and tar capabilities and are recorded in the special-action-flag field that is written to the FTP Server logfile. See xferlog(4). The following options are supported:
You can specify more than one option by using "|" to separate options. For example, O_TAR|O_COMPRESS specifies that the conversion archives and compresses.
Description is a one word description of the conversion that is used in error messages returned to the FTP client.
Lines that begin with a # sign are treated as comment lines and are ignored.
Example 1 Compressing a Regular File for Transfer
The following example specifies a conversion which generates filename.Z by compressing an existing file filename. The conversion can only be applied to regular files, not directories, and the absence of T_ASCII prevents the resulting file from being transferred in ASCII mode.
: : :.Z:/usr/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
Example 2 Uncompressing and Transferring in ASCII Mode
The following example specifies a conversion that takes filename.Z and uncompresses it to produce filename, which then can be transferred in ASCII mode.
:.Z: : :/usr/bin/compress -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
See attributes(5) for descriptions of the following attributes: