|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- configuration properties for Solaris SMB server
Behavior of the Solaris SMB server is defined by property values that are stored in the Service Management Facility, smf(5).
An authorized user can use the sharectl(1M) command to set global values for these properties in SMF.
The following list describes the properties:
Specifies the site configured in DNS to look up Active Directory information. Sites provide a mechanism to partition or delegate administration and policy management, which are typically used in large or complex domains.
The value should not be set if you do not have a local Active Directory site. By default, no value is set.
Specifies the full path for the SMD autohome map file, smbautohome. The default path is /etc.
A value that controls whether to disconnect the share or proceed if the map command fails. The disposition property only has meaning when the map property has been set. Otherwise it will have no effect.
disposition = [ continue | terminate ]
Proceed with share connection if the map command fails. This is the default in the event that disposition is not specified.
Disconnect the share if the map command fails.
Enables or disables dynamic DNS updates. A value of true enables dynamic updates, while a value of false disables dynamic updates. By default, the value is false.
Enables IPv6 Internet protocol support within the SMB Service. Valid values are true and false. The default value is false.
Specifies the number of seconds before an idle SMB connection is dropped by the Solaris SMB server. If set to 0, idle connections are not dropped. Valid values are 0 and from 20 seconds and above. The default value is 5400 seconds.
Specifies the LAN Manager (LM) authentication level. The LM compatibility level controls the type of user authentication to use in workgroup mode or domain mode. The default value is 3.
The following describes the behavior at each level.
In Windows workgroup mode, the Solaris SMB server accepts LM, NTLM, LMv2, and NTLMv2 requests. In domain mode, the SMB redirector on the Solaris SMB server sends NTLM requests.
In Windows workgroup mode, the Solaris SMB server accepts LM, NTLM, LMv2, and NTLMv2 requests. In domain mode, the SMB redirector on the Solaris SMB server sends LMv2 and NTLMv2 requests.
In Windows workgroup mode, the Solaris SMB server accepts NTLM, LMv2, and NTLMv2 requests. In domain mode, the SMB redirector on the Solaris SMB server sends LMv2 and NTLMv2 requests.
In Windows workgroup mode, the Solaris SMB server accepts LMv2 and NTLMv2 requests. In domain mode, the SMB redirector on the Solaris SMB server sends LMv2 and NTLMv2 requests.
The value is a command to be executed when connecting to the share. The command can take the following arguments, which will be substituted when the command is exec'd as described below:
Name of the domain or workgroup of %U.
The server hostname.
The client hostname, or "" if not available.
The server NetBIOS name.
The client NetBIOS name, or "" if not available. This option is only valid for NetBIOS connections (port 139).
The IP address of the client machine.
The local IP address to which the client is connected.
The name of the share.
The root directory of the share.
The UID of the Unix user.
Specifies the maximum number of worker threads that will be launched to process incoming SMB requests. The SMB max_mpx value, which indicates to a client the maximum number of outstanding SMB requests that it may have pending on the server, is derived from the max_workers value. To ensure compatibility with older versions of Windows the lower 8-bits of max_mpx must not be zero. If the lower byte of max_workers is zero, 64 is added to the value. Thus the minimum value is 64 and the default value, which appears in sharectl(1M) as 1024, is 1088.
Specifies the NetBIOS scope identifier, which identifies logical NetBIOS networks that are on the same physical network. When you specify a NetBIOS scope identifier, the server filters the number of machines that are listed in the browser display to make it easier to find other hosts. The value is a text string that represents a domain name. By default, no value is set.
Specifies the preferred IP address for the domain controller. This property is sometimes used when there are multiple domain controllers to indicate which one is preferred. If the specified domain controller responds, it is chosen even if the other domain controllers are also available. By default, no value is set.
Disables anonymous access to IPC$, which requires that the client be authenticated to get access to MSRPC services through IPC$. A value of true disables anonymous access to IPC$, while a value of false enables anonymous access.
Enables SMB signing. When signing is enabled but not required it is possible for clients to connect regardless of whether or not the client supports SMB signing. If a packet has been signed, the signature will be verified. If a packet has not been signed it will be accepted without signature verification. Valid values are true and false. The default value is false.
When SMB signing is required, all packets must be signed or they will be rejected, and clients that do not support signing will be unable to connect to the server. The signing_required setting is only taken into account when signing_enabled is true. Valid values are true and false. The default value is false.
Specifies an optional description for the system, which is a text string. This property value might appear in various places, such as Network Neighborhood or Network Places on Windows clients. By default, no value is set.
The value is a command to be executed when disconnecting the share. The command can take the same substitutions listed on the map property.
Specifies a comma-separated list of network interfaces that should not be registered with WINS. NetBIOS host announcements are made on excluded interfaces.
Specifies the IP address of the primary WINS server. By default, no value is set.
Specifies the IP address of the secondary WINS server. By default, no value is set.
See the attributes(5) man page for descriptions of the following attributes: