|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- FTP Server enhanced group access file
The ftpgroups file contains the enhanced group access information.
After login, if the ftpaccess(4) file includes private yes, the user may use the SITE GROUP and SITE GPASS commands to specify an enhanced access group and a password for that group. If the access group name and password are valid, the FTP Server executes setuid(2) to make the user a member of the real group listed in the ftpgroups file.
The format for the ftpgroups file is:
The fields are defined as follows:
An arbitrary string of alphanumeric and punctuation characters.
The group password encrypted exactly like in /etc/shadow.
The name of a valid group returned by getgrnam(3C).
The privatepw utility is an administrative tool to add, delete and list enhanced access group information in the ftpgroups file. See privatepw(1M). Lines that begin with a # sign are treated as comment lines and are ignored.
See attributes(5) for descriptions of the following attributes: