|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- file for telnet default options
The .telnetrc file contains commands that are executed when a connection is established on a per-host basis. Each line in the file contains a host name, one or more spaces or tabs, and a telnet(1) command. The host name, DEFAULT, matches all hosts. Lines beginning with the pound sign (#) are interpreted as comments and therefore ignored. telnet(1) commands are case-insensitive to the contents of the .telnetrc file.
The .telnetrc file is retrieved from each user's HOME directory.
Example 1 A sample file.
In the following example, a .telnetrc file executes the telnet(1) command, toggle:
weirdhost toggle crmod # Always export $PRINTER DEFAULT environ export PRINTER
The lines in this file indicate that the toggle argument crmod, whose default value is “off” (or FALSE), should be enabled when connecting to the system weirdhost. In addition, the value of the environment variable PRINTER should be exported to all systems. In this case, the DEFAULT keyword is used in place of the host name.
file for telnet default options