Go to main content

man pages section 7: Standards, Environments, Macros, Character Sets, and Miscellany

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ipadm (7)

Name

ifconfig, ipadm, dladm - mapping of ifconfig commands to ipadm and dladm utilities

Description

The ifconfig(8) command has largely been replaced by ipadm(8). There are also several features that are replaced by dladm(8), and a few replaced by other commands.

Modern network environments have become more complex, and configuration takes place on many different layers. The ipadm and dladm commands map directly to these layers, and have been designed to be extensible as new features are added. In addition, they have been designed such that the various components are managed in a uniform way; learning to configure a new type of network component should not require learning new command syntax. Finally, these commands also provide configuration persistence across a system reboot.

While the ipadm and dladm commands directly manage network configuration of the zone in which they are run, the global zone administrator can also manage or restrict network configuration within non-global zones using the zonecfg command. Please refer to zonecfg(8) for more details about this command.

To aid in the transition from ifconfig to the new commands, the following table provides translations from ifconfig options to the appropriate ipadm and dladm subcommands.


Note -  The syntax given in the table is not complete. Full syntax for each ipadm or dladm sub-command can be found by typing ipadm help sub-command or dladm help sub-command on the command-line. For example,
$ ipadm help create-ip

usage:

create-ip [-t] <IP-interface>

+==================+====================+=============================+
| ifconfig         | Description        | ipadm (other) command       |
+==================+====================+=============================+
| ifconfig -a      | List all           | ipadm                       |
|                  | interfaces         |                             |
|                  | and their          |                             |
|                  | addresses.         |                             |
+------------------+--------------------+-----------------------------+
| o plumb          | Create or delete   | ipadm create-ip             |
|                  | an IP              |                             |
| o unplumb        | interface.         | ipadm delete-ip             |
+------------------+--------------------+-----------------------------+
| [address]        | Create or delete   | ipadm create-addr a addr    |
|                  |                    |                             |
|  o addif         | a static IP        |                             |
|  o removeif      | address            | ipadm delete-addr           |
|  o netmask       | on an interface,   |                             |
|  o destination   | with or without    |                             |
|                  | an explicit        |                             |
|                  | netmask or         |                             |
|                  | prefix length.     |                             |
+------------------+--------------------+-----------------------------+
| dhcp[1]          | Create or delete   | ipadm create-addr           |
|                  |                    |                             |
|  o wait seconds  | DHCP address       |  T dhcp [wseconds]          |
|  o start         | on an              |                             |
|  o drop          | interface, with    | ipadm delete-addr           |
|  o release       | optional           |                             |
|                  | wait time          | ipadm delete-addr r         |
|                  | specified.         |                             |
+------------------+--------------------+-----------------------------+
| dhcp[1] extend   | Extend a DHCP      | ipadm refresh-addr          |
|                  | lease.             |                             |
+------------------+--------------------+-----------------------------+
| dhcp[1] inform   | Obtain             | ipadm refresh-addr i        |
|                  | configuration      |                             |
|                  | parameters from    |                             |
|                  | DHCP without       |                             |
|                  | obtaining          |                             |
|                  | a lease.           |                             |
+------------------+--------------------+-----------------------------+
| dhcp[1] ping     | Check if DHCP      | ipadm show-addr interface   |
|                  | is in use on an    |                             |
|                  | interface.         |                             |
+------------------+--------------------+-----------------------------+
| dhcp[1] status   | Display DHCP       | netstat D                   |
|                  | status.            |                             |
+------------------+--------------------+-----------------------------+
| o inet6 plumb up | Create or          | ipadm create-addr           |
| o token          | delete an          |  T addconf [i interface-id] |
|                  | auto-configured    |                             |
| o unplumb        | IPv6 address on    | ipadm delete-addr           |
|                  | an existing        |                             |
|                  | interface.         |                             |
+------------------+--------------------+-----------------------------+
| [-] deprecated   | View or set        | ipadm show-addrprop         |
| [-] preferred    | address            |                             |
| [-] private      | properties.        | ipadm set-addrprop          |
| [-] xmit         |                    |                             |
|                  |                    |                             |  
| zone             |                    |                             |
|  o -zones        |                    |                             |
|  o -all-zones    |                    |                             |
+------------------+--------------------+-----------------------------+
| up               | Bring an           | ipadm up-addr               |
|                  | address up.        | [implicit in                |
|                  |                    | the create-addr             |
|                  |                    | command;                    |
|                  |                    | only needed                 |
|                  |                    | after an explicit           |
|                  |                    | down-addr]                  |
+------------------+--------------------+-----------------------------+
| down             | Take an            | ipadm down-addr             |
|                  | address            |                             |
|                  | down.              |                             |
+------------------+--------------------+-----------------------------+
| o metric         | View or set        | ipadm show-ifprop           |
|                  | interface          |                             |
| o mtu            | properties.        | ipadm set-ifprop            |
|    [-] nud       |                    |                             |
|    [-] arp       |                    |                             |
|                  |                    |                             |
| o userrc         |                    |                             |
|    [-] router    |                    |                             |
|                  |                    |                             |
+------------------+--------------------+-----------------------------+
| o ipmp group name| Create or          | ipadm create-ipmp           |
|                  | delete an          |                             |
| o unplumb        | IPMP group.        | ipadm delete-ipmp           |
+------------------+--------------------+-----------------------------+
| group name       | Add an             | ipmp add-ipmp i ifname      |
|                  | interface          |                             |
|                  | to an              |                             |
|                  | IPMP group.        |                             |
+------------------+--------------------+-----------------------------+
| [-] standby      | Turn on/off        | ipadm set-ifprop            |
|                  | standby flag.      |  p standby=on               |
|                  |                    |                             |
|                  |                    | ipadm set-ifprop            |
|                  |                    |  p standby=off              |
+------------------+--------------------+-----------------------------+
| o tdst           | Configure a        | dladm *iptun subcommands    |
| o tsrc           | tunnel link.       |                             |
|    [-]encaplimit |                    |                             |
| o thoplimit      |                    |                             |
+------------------+--------------------+-----------------------------+
| ether addr       | View or set        | dladm show-linkprop         |
|                  | the hardware       |  p mac-address              |
|                  | address            |                             |
|                  | of a link.         | dladm set-linkprop          |
|                  |                    |  p mac-address=addr         |
+------------------+--------------------+-----------------------------+
| o modlist        | View or set        | dladm show-linkprop         |
|                  | modules to         |  p autopush                 |
|                  | be autopushed      |                             |
| o modinsert      | on a link.         | dladm set-linkprop          |
|                  |                    |  p autopush=modlist         |
|                  |                    |                             |
| o modremove      |                    |                             |
+------------------+--------------------+-----------------------------+
| o subnet         | Set subnet/        | ipadm set-addrprop          |
| o broadcast      | netmask/           |  p prefixlen=len            |
|                  | broadcast          |                             |
|                  | domain.            |                             |
+------------------+--------------------+-----------------------------+
| o auth_algs      | Set IPsec policy   | ipsecconf                   |
| o encr_algs      | for a tunnel link. |                             |
| o encr_auth_algs |                    |                             |
+------------------+--------------------+-----------------------------+
| o auto-revarp    |                    | These features are no       |
| o index          |                    | longer supported.           |
+----------------- +--------------------+-----------------------------+

See Also

dladm(8), ifconfig(8), ipadm(8), netstat(8), zonecfg(8)