solaris-oci - solaris-oci branded zone
The solaris-oci brand uses the branded zones framework described in brands to run Oracle Solaris images with the same software as is installed in the global zone. For more information, see the zones_brands(7) man page.
The solaris-oci brand instance expects that a consumer has configured the Oracle Solaris image and that all the system software is always in sync with the global zone.
The resources and properties that are supported by the solaris-oci brand are specified in the Open Container Initiative (OCI) runtime specification, as per, https://github.com/opencontainers/runtime-spec/blob/master/config-solaris.md.
There are specific default values for properties supported for solaris-oci brand as listed below:
Resource Property Default Value anet mac-address auto lower-link auto link-protection mac-nospoof
The live zone reconfiguration is not supported for solaris-oci brand.
The solaris-oci brand zones can only be administered using /usr/lib/brand/solaris-oci/runz command line utility which is OCI compliant.
In zonecfg command, only the info subcommand is allowed for solaris-oci brand zones. In zoneadm command, only the list subcommand is allowed for solaris-oci brand zones. For more information, see the zonecfg(8) and zoneadm(8) man pages.
See attributes(7) for descriptions of the following attributes: