|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Express 11/10|
- Sun Blade 10 Gigabit Ethernet network driver
The hxge Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on the Sun Blade Shared 10Gb Ethernet Interface.
The Shared PCI-Express 10 Gb networking interface provides network I/O consolidation for up to six Constellation blades, with each blade seeing its own portion of the network interface.
The hxge driver functions include chip initialization, frame transmit and receive, flow classification, multicast and promiscuous support and error recovery and reporting in the blade domain.
The cloning character-special device, /dev/hxge, is used to access Sun Blade Shared 10Gb Ethernet Interface devices installed within the system.
You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach
The values returned by the driver in the DL_INFO_ACK primitive in response to a DL_INFO_REQ are:
Maximum SDU is 1500 (ETHERMTU - defined in <sys/ethernet.h>).
Minimum SDU is 0.
DLSAP address length is 8.
MAC type is DL_ETHER.
SAP length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.
Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
Due to the nature of the link address definition for IPoIB, the DL_SET_PHYS_ADDR_REQ DLPI primitive is not supported.
In the transmit case for streams that have been put in raw mode via the DLIOCRAW ioctl, the dlpi application must prepend the 20 byte IPoIB destination address to the data it wants to transmit over-the-wire. In the receive case, applications receive the IP/ARP datagram along with the IETF defined 4 byte header.
Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular Service Access Point (SAP) with the stream.
The link speed and mode are fixed at 10 Gbps full-duplex.
The default MTU is 1500. To enable jumbo frame support, you configure the hxge driver by defining the accept-jumbo property to 1 in the hxge.conf file. Note that the largest jumbo size is 9178 bytes.
The driver may be configured to discard certain classes of traffic. By default, no class of traffic is allowed. You configure the hxge driver by defining the class option property to 0x20000 in hxge.conf to discard the specified class of traffic. For example, the following line in hxge.conf discards all IP Version 4 TCP traffic:
class-opt-ipv4-tcp = 0x20000;
You can also use the ndd(1M) command to configure the hxge driver at runtime to discard any classes of traffic.
The hxgedriver supports the self-healing functionality of Solaris OS. By default it is configured to DDI_FM_EREPORT_CAPABLE | DDI_FM_ERRCB_CAPABLE. You configure the hxge driver by defining the fm-capable property in hxge.conf to other capabilities or to 0x0 to disable it entirely.
The hxge driver may be configured using the standard ifconfig(1M) command.
The hxge driver also reports various hardware and software statistics data. You can view these statistics using the kstat(1M) command.
Special character device.
32–bit device driver (x86).
64–bit device driver (SPARC).
64–bit device driver (x86).
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide