|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Express 11/10|
- Serial Attached Management Protocol target driver
The smp target driver binds to SMP target devices such as SAS switches or SAS expanders. Unlike a SCSI target device, SMP target devices do not respond to a SCSI inquiry command. The SCSA framework can not enumerate SMP target devices by using the standard SCSI probe methods. To enumerate SMP target devices the SAS HBA driver must support target device self-discover and self-enumeration.
The smp driver exports the usmp(7I) interface to user processes. With the interface, SMP request and response frames are transported between the management applications and SMP target devices.
The access is restricted and device nodes created by the smp driver are readable and writable only by processes with the PRIV_SYS_DEVICES privilege exclusively.
The SMP target devices have device minor nodes created under the corresponding HBA path in /devices. Convenient links in the /dev/smp directory are created for the device minor nodes.
Driver configuration file.
smp device file, where X indicates a SMP target device instance.
See attributes(5) for a description of the following attributes:
Serial Attached SCSI —2, Revision 10
SCSI Primary Commands —4, Revision 7a