|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 11 Express 11/10|
- DTrace kernel lock instrumentation provider
The lockstat driver is a DTrace dynamic tracing provider that performs dynamic instrumentation for locking primitives in the Solaris kernel.
The lockstat provider makes probes available that you can use to discern lock contention statistics, or to understand virtually any aspect of locking behavior inside the operating system kernel. The lockstat(1M) command is implemented as a DTrace consumer that uses the lockstat provider to gather raw data.
The lockstat driver is not a public interface and you access the instrumentation offered by this provider through DTrace. Refer to the Solaris Dynamic Tracing Guide for a description of the public documented interfaces available for the DTrace facility and the probes offered by the lockstat provider.
See attributes(5) for a description of the following attributes:
Solaris Dynamic Tracing Guide