Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

bnxt (4D)

Name

bnxt - Broadcom 10/25GbE PCI Express NIC Driver

Synopsis

/dev/bnxt*

Description

The bnxt 10/25 Gigabit Ethernet driver is a multi-threaded, loadable, cloneable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi, on Broadcom E-Series 10/25 Gigabit Ethernet controllers. For more information, see the dlpi(4P) man page.

The bnxt driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.

Application Programming Interface

The cloning character-special device, /dev/bnxt, is used to access all Broadcom E-Series 10/25GbE PCI Express Ethernet devices installed within the system.

You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type, and indicates the corresponding device instance (unit) number. The driver returns an error, DL_ERROR_ACK, if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.

The values returned by the driver in the DL_INFO_ACK primitive in response to DL_INFO_REQ are:

  • Maximum SDU is 9582

  • Minimum SDU is 0

  • DLSAP address length is 8

  • MAC type is DL_ETHER

  • Service Access Point (SAP) length value is -2, which means that the physical address component is immediately followed by a 2-byte SAP component within the DLSAP address

  • Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF)

    Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular SAP with the stream

Configuration

The bnxt driver is managed by the dladm command line utility, which not only allows the VLANs to be defined on top of the bnxt instances, but also allows for the bnxt instances to be aggregated. For more information, see the dladm(8) man page.

Files

/dev/bnxt*

Special character device

/kernel/drv/amd64/bnxt

64-bit device driver for x86

/kernel/drv/sparcv9/bnxt

64-bit device driver for SPARC

/kernel/drv/bnxt.conf

Configuration file

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
driver/network/ethernet/bnxt
Architecture
SPARC, x86
Interface Stability
Committed

See Also

dladm(8), netstat(8), driver.conf(5), attributes(7), streamio(4I), dlpi(4P)

Writing Device Drivers in Oracle Solaris 11.4

STREAMS Programming Guide