Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Get_Status (4)

Name

Get_Status - retrieve a tool's current status

Synopsis

Get_Status(out string status,
out string vendor,
out string toolName,
out string toolVersion
[in messageID operation2Query]);

Description

Desktop Services Message Sets                                    Get_Status(4)



NAME
       Get_Status - retrieve a tool's current status

SYNOPSIS
       Get_Status(out string status,
                  out string vendor,
                  out string toolName,
                  out string toolVersion
                  [in messageID operation2Query]);

DESCRIPTION
       The  Get_Status  request  retrieves  the  current status of a tool (or,
       optionally, of a specific operation being performed by a tool).

       The status argument is the status retrieved.

       The vendor argument is the name of the vendor of the handling tool.

       The toolName argument is the name of the handling tool.

       The toolVersion argument is the version of the handling tool.

OPTIONAL ARGUMENTS
       The operation2Query argument is the ID of the  request  that  initiated
       the operation the status of which is being requested.

APPLICATION USAGE
       The  ttdt_session_join(3), and ttdt_message_accept(3), functions can be
       used to register for, and help process, the Get_Status request.

EXAMPLES
       After sending  a  TT_REQUEST  and  storing  its  handle  in  Tt_message
       request_I_sent,  if  the handler identifies itself with a Status notice
       saved  in  Tt_message  status_msg_from_handler,  then  the  status   of
       request_I_sent can be queried as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                    tt_message_sender(status_msg_from_handler),
                    TTDT_GET_STATUS, my_callback);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_IN, Tttk_string,
                        tt_message_id(request_I_sent));
            tt_message_send(msg);

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       tt_message_arg_add(3), tt_message_id(3), tt_message_send(3), ttdt_mes-
       sage_accept(3), tt_message_sender(3), ttdt_session_join(3).




ToolTalk 1.3                     1 March 1996                    Get_Status(4)