i40evf - Intel 10/40GbE Virtual Function Driver
The i40evf 10/40 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(4P), on the virtual function of Intel XL710 10/40 Gigabit Ethernet controllers.
The functions of i40evf driver include initialization of the virtual function, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.
The i40evf driver works on the virtual function of Intel XL710 10/40 Ethernet controller only when the SR-IOV capability of the controller is enabled.
The i40evf driver is managed by the dladm(8) command-line utility, which allows VLANs to be defined on top of i40evf instances. For more details, see the dladm(8) man page. Link aggregation is not supported on one or more i40evf interfaces.
The i40evf driver does not support link configuration. The link configuration is controlled by the physical function of the XL710 controller, which is supported by the i40e(4D) driver.
Special character device.
64-bit device driver (x86).
64-bit device driver (SPARC).
See attributes(7) for descriptions of the following attributes:
Network Interfaces Programmer's Guide