xsvhba - Oracle Virtual Host Bus Adapter driver
The xsvhba driver is a part of the Oracle Virtual Networking (OVN) I/O software stack, which is loaded and attached when the ovn-virtual-io service is enabled within the Oracle Solaris Service Management Facility. See smf(7). The driver is bound to a virtual host bus adapter (vHBA) device created in the Oracle Solaris device tree in response to a request to add a vHBA from the Fabric Interconnect (FI).
xsvhba is a upper layer protocol (ULP) driver that supports mechanisms for transporting SCSI-3 commands over Infiniband and then finally over the Fibre Channel I/O Module on the FI that connects to the Storage Area Network Fabric.
The driver is SCSAv3 compliant and hence supports Oracle Solaris I/O multipathing (MPxIO) feature. xsvhba also supports the Storage Networking Industry Association (SNIA) hbaapis, exported by libhbaapi(3LIB).
The driver is detached in response to a request from the FI by a delete operation. Administrators must ensure to temporarily disable the virtual HBA and the LUNs underneath, before performing a delete operation.
The xsvhba driver may operate with non-default properties as specified in the xsvhba.conf file. Note that the system must be rebooted for any changes to take effect. The following property is supported:
Oracle Solaris I/O Multipathing is enabled by default.
xsvhba may be disabled with the mpxio-disable property. To disable the feature, set the mpxio-disable property to 'yes' in the xsvhba.conf file.
To enable the feature, set the mpxio-disable property to 'no' in the xsvhba.conf file.
64-bit ELF kernel driver (SPARC)
64-bit ELF kernel driver (x86)
See attributes(7) for descriptions of the following attributes: