ncs - Network Conditions Simulator
NCS is a STREAMS module/driver which simulates network operating conditions in a lab environment. It captures packets from IP and manipulates the packets to simulate network conditions configured via ncsconfig(8).
NCS currently only operates on the output side. NCS can be visualized as being a router on the outgoing path. The return path remains unchanged.
NCS can be simultaneously activated on multiple IP interfaces, but the target list is shared among all those interfaces. Hence, if there are two interfaces which have NCS active, and A is on the target list, packets sent to target A will be impacted regardless of which interface is used. This is useful to test SCTP.
See attributes(7) for descriptions of the following attributes:
ncs module only works in global and kernel zone.