Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Set_Geometry (4)

Name

Set_Geometry - screen geometry

Synopsis

Set_Geometry(inout width w,
inout height h,
inout xOffset x,
inout yOffset y
[in messageID commission]);

Description

Desktop Services Message Sets                                  Set_Geometry(4)



NAME
       Set_Geometry - set a tool's on-screen geometry

SYNOPSIS
       Set_Geometry(inout width w,
                    inout height h,
                    inout xOffset x,
                    inout yOffset y
                    [in messageID commission]);

DESCRIPTION
       The  Set_Geometry request sets the on-screen geometry of the optionally
       specified window, or of the window primarily associated with the recip-
       ient procid (if no window is specified).

       The  w,  h,  x  and y arguments are integer geometry values, in pixels,
       representing width,  height,  x-coordinate  and  y-coordinate,  respec-
       tively.  Negative offset values are interpreted according to the X11(7)
       man page.  If any of these arguments are unset, that part of the geome-
       try  need not be changed.  The return values are the actual new values,
       in case they differ from the requested new values.

       The commission argument is the ID of the ongoing request, if any,  that
       resulted in the creation of the window in question.

APPLICATION USAGE
       The  ttdt_session_join(3), and ttdt_message_accept(3), functions can be
       used by Xt applications to register for, and transparently process, the
       Set_Geometry request.

EXAMPLES
       The Set_Geometry request can be sent as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                        the_recipient_procid, TTDT_SET_GEOMETRY,
                        my_callback);
            tt_message_iarg_add(msg, TT_INOUT, Tttk_width, 500);
            tt_message_iarg_add(msg, TT_INOUT, Tttk_height, 500);
            tt_message_arg_add(msg, TT_INOUT, Tttk_xoffset, 0); /* no value */
            tt_message_arg_add(msg, TT_INOUT, Tttk_yoffset, 0); /* no value */
            tt_message_send(msg);

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       tt_message_arg_add(3), tt_message_iarg_add(3), tt_message_send(3),
       ttdt_message_accept(3), ttdt_session_join(3); Get_Geometry request.




ToolTalk 1.3                     1 March 1996                  Set_Geometry(4)