jconvrs - code conversion STREAMS module (Japanese EUC/PC kanji)
ioctl(fd, I_PUSH, "jconvrs");
jconvrs is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between terminal circuit module such as ldterm(4M) and STREAMS compatible module such as ttcompat(4M).
jconvrs has to be pushed when you operate PC kanji data. It converts up stream for Japanese EUC into PC kanji code and passes high module. It also converts down stream for PC kanji code into Japanese EUC and passes low module. jconvrs controls terminal circuit under PCK environment by using with jconvs(4M).
jconvrs processes the following ioctls:
Start performing code conversion between Japanese EUC and PC kanji for I/O stream.
Stop performing code conversion between Japanese EUC and PC kanji for I/O stream.
See attributes(7) for descriptions of the following attributes:
When you use jconvrs with jconvs(4M), jconvu(4M), jconv7(4M), or jconv8(4M) at a time and ‘raw’ is specified by stty(1), code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF .
jconvrs supports PC kanji/Japanese EUC code conversion under TOG Japanese Vendors Council (TOG/JVC) Recommended Code Set Conversion Specification between Japanese EUC and Shift–JIS.