Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

mlxne (4D)

Name

mlxne - Mellanox 100GbE PCI Express NIC Driver

Synopsis

/dev/mlxne*

Description

The mlxne driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(4P), on Mellanox ConnectX 100 Gigabit Ethernet and VPI devices.

The mlxne driver functions include device initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.

Application Programming Interface

The cloning character-special device, /dev/mlxne, is used to access all Mellanox ConnectX 100 Gigabit Ethernet and VPI devices installed within the system.

You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type, and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at the last detach.

The values returned by the driver in the DL_INFO_ACK primitive in response to DL_INFO_REQ are:

  • Maximum SDU is 9978.

  • Minimum SDU is 1500.

  • DLSAP address length is 8.

  • MAC type is DL_ETHER.

  • SAP (Service Access Point) length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.

  • Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).

    Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular SAP with the stream.

Configuration

The mlxne driver is managed by the dladm(8) command-line utility, which allows VLANs to be defined on top of mlxne instances and for mlxne instances to be aggregated. See dladm(8) for more details.

Files

/dev/mlxne*

Special character device.

/kernel/drv/amd64/mlxne

64-bit device driver (x86).

/kernel/drv/sparcv9/mlxne

64-bit device driver (SPARC).

/kernel/drv/mlxne.conf

Configuration file.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
driver/network/ethernet/mlxne
Architecture
SPARC, x86
Interface Stability
Committed

See Also

streamio(4I), dlpi(4P), driver.conf(5), attributes(7), dladm(8), netstat(8)

Writing Device Drivers in Oracle Solaris 11.4

STREAMS Programming Guide

IEEE 802.3ae Specification, IEEE - 2002

https://standards.ieee.org/standard/802_3ae-2002.html