Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Signal (4)

Name

Signal - style) signal to a tool

Synopsis

Signal(in string theSignal);

Description

Desktop Services Message Sets                                        Signal(4)



NAME
       Signal - send a (POSIX-style) signal to a tool

SYNOPSIS
       Signal(in string theSignal);

DESCRIPTION
       The  Signal  request  asks the handling procid to send itself the indi-
       cated POSIX signal.

       The theSignal argument is the signal to send.

APPLICATION USAGE
       The ttdt_session_join(3), function can be used  to  register  for,  and
       transparently process, the Signal request.

EXAMPLES
       The Signal request can be sent as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                        the_recipient_procid, TTDT_SIGNAL,
                        my_callback);
            tt_message_arg_add(msg, TT_IN, Tttk_string, "SIGHUP");
            tt_message_send(msg);

WARNINGS
       Signal can also be sent as a multicast notice, as an edict to all tools
       in the scope of the message.  The  consequences  of  doing  so  can  be
       severe and unexpected.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       sigaction(2) tt_message_arg_add(3), tt_message_send(3), ttdt_ses-
       sion_join(3),




ToolTalk 1.3                     1 March 1996                        Signal(4)