Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Get_Sysinfo (4)

Name

Get_Sysinfo - get information about a tool's host

Synopsis

Get_Sysinfo(out string sysname,
out string nodename,
out string release,
out string version,
out string machine);

Description

Desktop Services Message Sets                                   Get_Sysinfo(4)



NAME
       Get_Sysinfo - get information about a tool's host

SYNOPSIS
       Get_Sysinfo(out string sysname,
                   out string nodename,
                   out string release,
                   out string version,
                   out string machine);

DESCRIPTION
       The Get_Sysinfo request gets information about the handler's host.

       The sysname argument is the name of the host's operating system.

       The nodename argument is the name of the host.

       The  release and version arguments are implementation-specific informa-
       tion about the host's operating system.

       The machine argument is an implementation-specific name that identifies
       the hardware on which the operating system is running.

APPLICATION USAGE
       The  ttdt_session_join(3),  function  can  be used to register for, and
       transparently process, the Get_Sysinfo request.

EXAMPLES
       The Get_Sysinfo message can be sent as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                        the_recipient_procid, TTDT_GET_SYSINFO,
                        my_callback);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_send(msg);

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       uname(2) tt_message_arg_add(3), tt_message_send(3), ttdt_ses-
       sion_join(3).




ToolTalk 1.3                     1 March 1996                   Get_Sysinfo(4)