Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Get_XInfo (4)

Name

Get_XInfo - get a tool's X11 attributes

Synopsis

Get_XInfo(out string display,
out string visual,
out integer depth
[in messageID commission]);

Description

Desktop Services Message Sets                                     Get_XInfo(4)



NAME
       Get_XInfo - get a tool's X11 attributes

SYNOPSIS
       Get_XInfo(out string display,
                 out string visual,
                 out integer depth
                 [in messageID commission]);

DESCRIPTION
       The  Get_XInfo  request  reports  the  X11 attributes of the optionally
       specified window, or of the window primarily associated with the recip-
       ient procid (if no window is specified).

       The display argument is an X11 display.

       The  visual  argument  is  an  X11 visual class (which determines how a
       pixel will be displayed as a color).  Valid values are:

            StaticGray
            GrayScale
            StaticColor
            PseudoColor
            TrueColor
            DirectColor

       The depth argument is the number of bits in a pixel.

       The commission argument is the ID of the ongoing request  with  respect
       to which X11 attributes are being set or reported.

APPLICATION USAGE
       The  ttdt_session_join(3), and ttdt_message_accept(3), functions can be
       used by Xt applications to register for, and transparently process, the
       Get_XInfo    request.     Also,    Get_XInfo    can    be    sent    by
       ttdt_sender_imprint_on(3).

       Since the handler may be running on a  different  host,  it  is  almost
       always  better  to  return a display value of hostname:n[.n] instead of
       :n[.n].)

       The commission argument is  useful  to  the  extent  that  the  handler
       employs  different  attributes  for  the different operations it may be
       carrying out.

EXAMPLES
       The Get_XInfo request can be sent as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                        the_recipient_procid, TTDT_GET_XINFO,
                        my_callback);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_arg_add(msg, TT_OUT, Tttk_string, 0);
            tt_message_iarg_add(msg, TT_OUT, Tttk_integer, 0);
            tt_message_send(msg);

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       tt_message_iarg_add(3), tt_message_send(3), ttdt_message_accept(3),
       ttdt_sender_imprint_on(3), ttdt_session_join(3).




ToolTalk 1.3                     1 March 1996                     Get_XInfo(4)