Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Set_Iconified (4)

Name

Set_Iconified - set a tool's iconic state

Synopsis

Set_Iconified(out boolean iconic
[in messageID commission]);

Description

Desktop Services Message Sets                                 Set_Iconified(4)



NAME
       Set_Iconified - set a tool's iconic state

SYNOPSIS
       Set_Iconified(out boolean iconic
                     [in messageID commission]);

DESCRIPTION
       The Set_Iconified request sets the iconic state of the optionally spec-
       ified window, or of the window primarily associated with  the  handling
       procid (if no window is specified).

       The iconic argument is a Boolean value indicating whether the specified
       window is (to be) iconified.

       The commission argument is the ID of the ongoing request, if any,  that
       resulted in the creation of the window(s) in question.

APPLICATION USAGE
       The  ttdt_session_join(3), and ttdt_message_accept(3), functions can be
       used by Xt applications to register for, and transparently process, the
       Set_Iconified request.

       If the handler does not map window-system windows one-to-one to commis-
       sions or procids, then it may  interpret  ``iconic  state''  liberally.
       For example, consider a Display request on an ISO_Latin_1 file, handled
       by a gnuemacs instance that then devotes an  emacs  ``window''  to  the
       file.   ``Windows''  in  gnuemacs are not separate X11 windows, and are
       not separately iconifiable.  However, a  Set_Iconified  request  issued
       with  respect  to the ongoing Display request could be liberally inter-
       preted by gnuemacs to mean it should minimize the  screen  real  estate
       devoted to the operation, perhaps by ``burying'' the buffer or dividing
       its window's real estate among neighboring windows.  And, if  the  Dis-
       play  request  happens  to be the only thing emacs is working on at the
       moment, it could instead take a literal  interpretation,  and  actually
       iconify itself.

EXAMPLES
       The Set_Iconified request can be sent as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                        the_recipient_procid, TTDT_SET_ICONIFIED,
                        my_callback);
            tt_message_iarg_add(msg, TT_IN, Tttk_boolean, 1);
            tt_message_send(msg);

WARNINGS
       Set_Iconified  can  also  be sent as a multicast notice, as an edict to
       all tools in the scope of the message.  The consequences  of  doing  so
       can be severe and unexpected.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       tt_message_iarg_add(3), tt_message_send(3), ttdt_message_accept(3),
       ttdt_session_join(3); Get_Iconified request.




ToolTalk 1.3                     1 March 1996                 Set_Iconified(4)