jconvs - code conversion STREAMS module (PC kanji/Japanese EUC)
ioctl(fd, I_PUSH, "jconvs");
jconvs is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between a raw device such as ptem(4M) and terminal line discipline module such as ldterm(4M).
jconvs has to be pushed when you set PC kanji terminal. It converts up stream for PC kanji code into Japanese EUC and passes high module. It also converts down stream for Japanese EUC into PC kanji code and passes low module. jconvs controls terminal line discipline under PCK environment by using with jconvrs(4M).
jconvs processes the following ioctls:
Start performing code conversion between PC kanji and Japanese EUC for I/O stream.
Stop performing code conversion between PC kanji and Japanese EUC for I/O stream.
See attributes(7) for descriptions of the following attributes:
jconvs supports PC kanji/Japanese EUC code conversion under TOG Japanese Vendors Council (TOG/JVC) Recommended Code Set Conversion Specification between Japanese EUC and Shift–JIS.