Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

jconvru (4M)

Name

jconvru - code conversion STREAMS module (Japanese EUC/UTF—8)

Synopsis

#include <sys/types.h>
#include <sys/stropt.h>
#include <sys/conf.h>
ioctl(fd, I_PUSH, "jconvru");

Description

jconvru is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between terminal circuit module such as ldterm(4M) and STREAMS compatible module such as ttcompat(4M).

jconvru has to be pushed when you operate UTF-8 data. It converts up stream for Japanese EUC into UTF-8 and passes high module. It also converts down stream for UTF-8 into Japanese EUC and passes low module.

Ioctls

jconvru processes the following ioctls:

EUC_OXLON

Start performing code conversion between Japanese EUC and UTF-8 for I/O stream.

EUC_OXLOFF

Stop performing code conversion between Japanese EUC and UTF-8 for I/O stream.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/locale/extra

See Also

setterm(1), stty(1), streamio(4I), jconv7(4M), jconv8(4M), jconvrs(4M), jconvs(4M), jconvu(4M), ldterm(4M), ptem(4M)

Notes

When you use jconvru with jconvu(4M), jconvs(4M), jconv7(4M), or jconv8(4M) at a time and ‘raw’ is specified by stty(1), code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF.