Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Print (4)

Name

Print - print a document

Synopsis

[file] Print(in mediaType contents,
in boolean inquisitive,
in boolean covert
[in title docName]);

Description

Document and Media Exchange Message Sets                              Print(4)



NAME
       Print - print a document

SYNOPSIS
       [file] Print(in mediaType contents,
                    in boolean inquisitive,
                    in boolean covert
                    [in title docName]);

DESCRIPTION
       The  Print request causes the handler to print a document.  The handler
       must act as if the user had issued, (via the handler's user  interface)
       either  a ``Print One'' or ``Print...'' command, depending on the value
       of the inquisitive argument.

       The contents argument is the contents of the document.  If  this  argu-
       ment is unset (in other words, has a value of (char *)0), then the con-
       tents of the document are in the  file  named  in  the  message's  file
       attribute.   The  data type (mediaType) of the contents argument should
       be string, unless nulls are valid in the given  media  type,  in  which
       case the data type must be bytes.

       The inquisitive argument is a boolean value indicating whether the han-
       dler is allowed to block on user input while carrying out the  request.
       However,  even  if  inquisitive is True, the handler is not required to
       seek such input.

       The covert argument is a boolean value indicating whether  the  handler
       may make itself apparent to the user as it carries out the request.  If
       False, the recipient need not make itself apparent.

       If both the inquisitive argument and the covert argument are True,  the
       recipient should attempt to limit its presence to the minimum needed to
       receive any user input desired; for example, through iconification.

       The docName argument contains the name of the document.  If the docName
       argument is absent and the file attribute is set, the file name is con-
       sidered to be the title of the document.  This string would be suitable
       for display in a window title bar, for example.

APPLICATION USAGE
       The  ttmedia_ptype_declare(3) function can be used to register for, and
       help process, this message.

       This message can be sent with the ttmedia_load(3) function.

EXAMPLES
       To print a PostScript document, the application can send a  request  of
       the form:

            Print(in PostScript contents,
                  in boolean inquisitive,
                  in boolean covert);

       with a first argument whose value is a vector of bytes such as:

            %!\n/inch {72 mul} def...

       The \n in the example represents the newline character.

       To print a PostScript document contained in a file, the application can
       send the Print request as above, with the file  attribute  set  to  the
       relevant file and with the value of the first argument not set.

ERRORS
       The ToolTalk service may return one of the following errors in process-
       ing the Print request:

          TT_DESKTOP_ENOENT
                The file that was alleged to contain  the  document  does  not
                exist.

          TT_DESKTOP_ENODATA
                The  in-mode  contents  argument  had  no  value  and the file
                attribute of the message was not set.

          TT_MEDIA_ERR_FORMAT
                The document is not a valid instance of the media type.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       ttmedia_ptype_declare(3), ttmedia_load(3); Intro, Status requests.




ToolTalk 1.3                     1 March 1996                         Print(4)