xstn - Oracle Virtual I/O Transportnexusdriver
The xstn driver is a part of the Oracle Virtual Networking (OVN) I/O software stack, which is loaded and attached when the ovn-virtual-io service is enabled within the Oracle Solaris Service Management Facility. See smf(7).
xstn is a nexus driver and registers with the Infiniband (IB) framework as a virtual physical point of attachment (VPPA) service provider. The driver detects all the fabric interconnect (FI) devices in the IB subnet and establishes a communication channel with each FI, over which virtual I/O device management messages are received.
The virtual I/O devices such as the virtual network interface cards (vNICs) and virtual host bus adapters (vHBAs) are represented in the Oracle Solaris device tree with the node name bearing the same name specified in the I/O profile configured on the FI.
A vNIC node is bound by the xsvnic(4D) driver instance, while the vHBA node is bound by the xsvhba(4D) driver instance. This driver handles all the install and delete messages received from the FI and updates the device tree topology accordingly.
Administrators must ensure to temporarily disable the virtual device before performing a delete operation. This driver is detached from the IB framework when the smf service is disabled.
64-bit ELF kernel driver (SPARC)
64-bit ELF kernel driver (x86)
See attributes(7) for descriptions of the following attributes: