xstl - Oracle Virtual I/O Transport layer
The xstl module is a part of the Oracle Virtual Networking (OVN) I/O software stack, which is loaded and attached when the ovn-virtual-io service is enabled within the Oracle Solaris Service Management Facility. See smf(7).
xstl is an Oracle Solaris kernel misc module, which uses the Infiniband (IB) transport layer services exported by ibtl(4D). Apart from providing a programming interface to the virtual I/O device drivers such as xsvnic(4D) and xsvhba(4D), xstl also manages the connections with the Fabric Interconnect (FI) devices in the IB subnet, in coordination with the xstn(4D) driver.
64-bit ELF kernel driver (SPARC)
64-bit ELF kernel driver (x86)
See attributes(7) for descriptions of the following attributes: