Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Edit (4)

Name

Edit - compose or edit a document

Synopsis

[file] Edit([out|inout] mediaType contents
[in title docName]);

Description

Document and Media Exchange Message Sets                               Edit(4)



NAME
       Edit - compose or edit a document

SYNOPSIS
       [file] Edit([out|inout] mediaType contents
                   [in title docName]);

DESCRIPTION
       The  Edit  request causes the handler to edit a document and reply with
       the new contents when the editing is completed.

       It is up to the handler to decide issues such as:

          o  When the editing operation can be deemed completed

          o  What user gesture signals the completion of the editing

          o  What the handling tool should do with itself after replying

       If the handling tool supports some form of intermediate save  operation
       during  editing,  it  must send a Deposit request back to the tool that
       requested the Edit.

       The contents argument is the contents of the document.  If  this  argu-
       ment is unset (in other words, has a value of (char *)0), then the con-
       tents of the document are in the  file  named  in  the  message's  file
       attribute.   The  data type (mediaType) of the contents argument should
       be string, unless nulls are valid in the given  media  type,  in  which
       case the data type must be bytes.

       If  the  contents  argument is of mode out, then a new document must be
       composed and its contents returned in this argument.

       The docName argument contains the name of the document.  If the docName
       argument is absent and the file attribute is set, the file name is con-
       sidered to be the title of the document.  This string would be suitable
       for display in a window title bar, for example.

APPLICATION USAGE
       The  ttmedia_ptype_declare(3) function can be used to register for, and
       help process, this message.

       This message can be sent with the ttmedia_load(3) function.

EXAMPLES
       To edit an X11 XBM bitmap, the application can  send  an  Edit  request
       with  a  first argument whose vtype is XBM, and whose value is a string
       such as:

            #define foo_width 44\n#define foo_height 94\n

       The \n in the example represents the newline character.

       To edit an X11 XBM bitmap contained in a file, the application can send
       an  Edit  request  naming that file in its file attribute, with a first
       argument whose vtype is XBM, and whose value is not set.

ERRORS
       The ToolTalk service may return one of the following errors in process-
       ing the Edit request:

          TT_DESKTOP_ECANCELED
                The  user  overrode the Edit request.  When an Edit request is
                failed with TT_DESKTOP_ECANCELED, the document should  not  be
                updated as a result, but rather should remain as it was before
                the failure reply was received.

          TT_DESKTOP_ENOENT
                The file that was alleged to contain  the  document  does  not
                exist.

          TT_DESKTOP_ENODATA
                The  in-mode  contents  argument  had  no  value  and the file
                attribute of the message was not set.

          TT_MEDIA_ERR_FORMAT
                The document is not a valid instance of the media type.

ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       ttmedia_ptype_declare(3), ttmedia_load(3); Intro, Display requests.




ToolTalk 1.3                     1 March 1996                          Edit(4)