Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

jconv7 (4M)

Name

jconv7 - code conversion STREAMS module (7-bit JIS/Japanese EUC)

Synopsis

#include <sys/types.h>
#include <sys/stropt.h>
#include <sys/conf.h>
ioctl(fd, I_PUSH, "jconv7");

Description

jconv7 is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between a raw device such as ptem(4M) and terminal line discipline module such as ldterm(4M).

jconv7 has to be pushed when you set 7–bit JIS terminal and control Japanese EUC data. It converts up stream for 7–bit JIS code into Japanese EUC and passes high module. It also converts down stream for Japanese EUC into 7–bit JIS code and passes low module.

Ioctls

jconv7 processes the following ioctls. JA_SKIOC and JA_GKIOC are specified pointers to the next structure as argument:


struct kioc {
char ki;
char ko;
};
JA_SKIOC

Change the third character of JIS kanji and ASCII indication escape sequence.

JA_GKIOC

Return the third character of current JIS kanji and ASCII indication escape sequence.

EUC_OXLON

Start performing code conversion between 7–bit JIS and Japanese EUC for I/O stream.

EUC_OXLOFF

Stop performing code conversion between 7–bit JIS and Japanese EUC for I/O stream.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/locale/extra

See Also

setterm(1), stty(1), streamio(4I), jconv8(4M), jconvrs(4M), jconvru(4M), jconvs(4M), jconvu(4M), ldterm(4M), ptem(4M)

Notes

When you use jconv7 with jconvrs(4M) or jconvru(4M) at a time and ‘raw’ is specified by stty(1), code convert function automatically becomes off without specification by EUC_OXLON / EUC_OXLOFF . By default, character set indication escape sequences is as follows. The end character may be changed by JA_SKIOC.

  • ASCII indication: ESC 2/8 4/10

  • Character indication: ESC 2/4 4/2

  • Convert with JIS X 0201 Kana: SI/SO

jconv7 does not support Kanji code for Information Interchange (secondary kanji set) provided by JIS X 0212–1990.

When jconv7 is in use, csh(1) does not work properly for filename additional function.