Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

Set_Environment (4)

Name

Set_Environment - set a tool's environment

Synopsis

Set_Environment(in string variable,
in string value
[...]);

Description

Desktop Services Message Sets                               Set_Environment(4)



NAME
       Set_Environment - set a tool's environment

SYNOPSIS
       Set_Environment(in string variable,
                       in string value
                       [...]);

DESCRIPTION
       The  Set_Environment  request replaces the value of the indicated envi-
       ronment variable(s).

       The variable argument is the name of the environment variable to set.

       The value argument is the value of the environment variable.   If  this
       argument  is unset (in other words, has a value of (char *)0), then the
       variable should be removed from the environment.  It is  not  an  error
       for the variable not to have existed in the first place.

APPLICATION USAGE
       The  ttdt_session_join(3),  function  can  be used to register for, and
       transparently process, the Set_Environment request.

EXAMPLES
       The Set_Environment request can be sent as in the following example:

            Tt_message msg = tttk_message_create(0, TT_REQUEST, TT_SESSION,
                        the_recipient_procid, TTDT_SET_ENVIRONMENT,
                        my_callback);
            tt_message_arg_add(msg, TT_IN, Tttk_string, "PATH");
            tt_message_arg_add(msg, TT_IN, Tttk_string, "/bin:/usr/ucb");
            tt_message_send(msg);

WARNINGS
       Set_Environment can also be sent as a multicast notice, as an edict  to
       all  tools  in  the scope of the message.  The consequences of doing so
       can be severe and unexpected.


ATTRIBUTES
       See attributes(7) for descriptions of the following attributes:


       +---------------+------------------+
       |ATTRIBUTE TYPE | ATTRIBUTE VALUE  |
       +---------------+------------------+
       |Availability   | library/tooltalk |
       +---------------+------------------+
       |Stability      | Committed        |
       +---------------+------------------+

SEE ALSO
       tt_message_arg_add(3), tt_message_send(3), ttdt_session_join(3);
       Get_Environment request.




ToolTalk 1.3                     1 March 1996               Set_Environment(4)